Welligent EHR: Reported Slowness

Incident Report for Welligent

Resolved

System performance has returned to normal, and no further reports have been received.
Posted Aug 06, 2026 - 12:30 EDT

Investigating

Welligent is investigating and monitoring after reports of system degradation by some agencies. System performance is returning to normal at this time.
Posted Aug 06, 2026 - 11:14 EDT
This incident affected: Welligent Production.