Welligent EHR: Scheduled Maintenance 04/23/2026 5AM EDT (2AM PDT)

Scheduled for Apr 23, 05:00 - 05:45 EDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Apr 17, 2026 - 13:41 EDT

Update

Welligent will perform system maintenance on Thursday, April 23rd at 5:00AM EDT (2:00AM PDT). The system may be unavailable for up to 45 minutes.  Visit Welligent Community for more information through our Release Notes section.
Posted Apr 17, 2026 - 13:40 EDT

Scheduled

Welligent will perform system maintenance on Thursday, April 23rd at 5:00AM EDT (2:00AM PDT). The system may be unavailable for up to 45 minutes.  Visit Welligent Community for more information through our Release Notes section.
Posted Apr 17, 2026 - 10:28 EDT
This scheduled maintenance affects: Welligent Production.